const regex = /, (?![^()]*\))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(', (?![^()]*\\))', 'g')
const str = `key1: val1, key2: (val2.1, val2.2, val2.3), key3: (), key4: val4`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);