import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\d{8}/";
final String string = "https://cdn.mydomain.com/wp-content/uploads/2020/05**/20125258/**image1.jpg\n"
+ "https://cdn.mydomain.com/wp-content/uploads/2021/10**/13440323/**image-ex2.jpg\n"
+ "https://cdn.mydomain.com/wp-content/uploads/2012/01**/92383422/**my-image3.jpg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}