$re = '@/\d{8}/@';
$str = 'https://cdn.mydomain.com/wp-content/uploads/2020/05**/20125258/**image1.jpg
https://cdn.mydomain.com/wp-content/uploads/2021/10**/13440323/**image-ex2.jpg
https://cdn.mydomain.com/wp-content/uploads/2012/01**/92383422/**my-image3.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);