using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?P<a>[0-9]*)\/(?P<b>[0-9]*-[0-9]*)@g.us\((?P<c>(?:[0-9]{2}\-){2}2015) [0-9]{2}:[0-9]{2}\)\]:\[(?P<d>[A-Z0-9a-z]{13}|.*)\](?P<e>.*)\nMessage (?P=d): Sent delivered receipt\n\[connected]:";
string input = @"[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator
Message AC103CD12DER5: Sent delivered receipt
[connected]:
[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator
Message AC103CD12DER5: Sent delivered receipt
[connected]:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}