import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?P<a>[0-9]*)\\/(?P<b>[0-9]*-[0-9]*)@g.us\\((?P<c>(?:[0-9]{2}\\-){2}2015) [0-9]{2}:[0-9]{2}\\)\\]:\\[(?P<d>[A-Z0-9a-z]{13}|.*)\\](?P<e>.*)\\nMessage (?P=d): Sent delivered receipt\\n\\[connected]:";
final String string = "[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator\n"
+ "Message AC103CD12DER5: Sent delivered receipt\n"
+ "[connected]:\n\n"
+ "[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator\n"
+ "Message AC103CD12DER5: Sent delivered receipt\n"
+ "[connected]:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}