const regex = new RegExp('\\[(?P<a>[0-9]*)\\/(?P<b>[0-9]*-[0-9]*)@g.us\\((?P<c>(?:[0-9]{2}\\-){2}2015) [0-9]{2}:[0-9]{2}\\)\\]:\\[(?P<d>[A-Z0-9a-z]{13}|.*)\\](?P<e>.*)\\nMessage (?P=d): Sent delivered receipt\\n\\[connected]:', 'g')
const str = `[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator
Message AC103CD12DER5: Sent delivered receipt
[connected]:
[1234567890123/123456789012-1234567898@g.us(18-10-2015 11:30)]:[AC103CD12DER5] VW Simulator
Message AC103CD12DER5: Sent delivered receipt
[connected]:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}