#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bsession-id=\d+\b"
Local $sString = "www.somewebsite.com/misc-session/;session-id=213213213" & @CRLF & _
"www.somewebsite.com/misc-session/;session-id=213213213?someExtraParam=false" & @CRLF & _
"" & @CRLF & _
"or" & @CRLF & _
"" & @CRLF & _
"www.somewebsite.com/misc-session/extra-path/;session-id=213213213?someExtraParam=false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")