import Foundation
let pattern = #"\bsession-id=\d+\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
www.somewebsite.com/misc-session/;session-id=213213213
www.somewebsite.com/misc-session/;session-id=213213213?someExtraParam=false
or
www.somewebsite.com/misc-session/extra-path/;session-id=213213213?someExtraParam=false
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)