using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bsession-id=\d+\b";
string input = @"www.somewebsite.com/misc-session/;session-id=213213213
www.somewebsite.com/misc-session/;session-id=213213213?someExtraParam=false
or
www.somewebsite.com/misc-session/extra-path/;session-id=213213213?someExtraParam=false";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}