// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bsession-id=\d+\b").unwrap();
let string = "www.somewebsite.com/misc-session/;session-id=213213213
www.somewebsite.com/misc-session/;session-id=213213213?someExtraParam=false
or
www.somewebsite.com/misc-session/extra-path/;session-id=213213213?someExtraParam=false";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}