re = /\bsession-id=\d+\b/
str = 'www.somewebsite.com/misc-session/;session-id=213213213
www.somewebsite.com/misc-session/;session-id=213213213?someExtraParam=false
or
www.somewebsite.com/misc-session/extra-path/;session-id=213213213?someExtraParam=false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end