# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[0-9][^.](januar($| |\n)|februar($| |\n)|mars($| |\n)|april($| |\n)|mai($| |\n)|juni($| |\n)|juli($| |\n)|august($| |\n)|september($| |\n)|oktober($| |\n)|november($| |\n)|desember($| |\n))//g;t' <<< "15. januar
15 januar
24. februar spiste jeg en katt.
24 februar spiste jeg en katt."