re = /[0-9][^.](januar($| |\n)|februar($| |\n)|mars($| |\n)|april($| |\n)|mai($| |\n)|juni($| |\n)|juli($| |\n)|august($| |\n)|september($| |\n)|oktober($| |\n)|november($| |\n)|desember($| |\n))/
str = '15. januar
15 januar
24. februar spiste jeg en katt.
24 februar spiste jeg en katt.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result