import Foundation
let pattern = #"[0-9][^.](januar($| |\n)|februar($| |\n)|mars($| |\n)|april($| |\n)|mai($| |\n)|juni($| |\n)|juli($| |\n)|august($| |\n)|september($| |\n)|oktober($| |\n)|november($| |\n)|desember($| |\n))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
15. januar
15 januar
24. februar spiste jeg en katt.
24 februar spiste jeg en katt.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)