const regex = /[0-9][^.](januar($| |\n)|februar($| |\n)|mars($| |\n)|april($| |\n)|mai($| |\n)|juni($| |\n)|juli($| |\n)|august($| |\n)|september($| |\n)|oktober($| |\n)|november($| |\n)|desember($| |\n))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[0-9][^.](januar($| |\\n)|februar($| |\\n)|mars($| |\\n)|april($| |\\n)|mai($| |\\n)|juni($| |\\n)|juli($| |\\n)|august($| |\\n)|september($| |\\n)|oktober($| |\\n)|november($| |\\n)|desember($| |\\n))', 'g')
const str = `15. januar
15 januar
24. februar spiste jeg en katt.
24 februar spiste jeg en katt.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);