using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[0-9][^.](januar($| |\n)|februar($| |\n)|mars($| |\n)|april($| |\n)|mai($| |\n)|juni($| |\n)|juli($| |\n)|august($| |\n)|september($| |\n)|oktober($| |\n)|november($| |\n)|desember($| |\n))";
string substitution = @"";
string input = @"15. januar
15 januar
24. februar spiste jeg en katt.
24 februar spiste jeg en katt.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}