using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([0-9]+[\s,]*)+)(\$|EUR)";
string input = @"1000$ and 5 000 EUR and 2 000 , 00 $ and 3000,00 EUR";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}