$re = '/(([0-9]+[\s,]*)+)(\$|EUR)/';
$str = '1000$ and 5 000 EUR and 2 000 , 00 $ and 3000,00 EUR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);