// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(([0-9]+[\s,]*)+)(\$|EUR)").unwrap();
let string = "1000$ and 5 000 EUR and 2 000 , 00 $ and 3000,00 EUR";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}