re = /(([0-9]+[\s,]*)+)(\$|EUR)/
str = '1000$ and 5 000 EUR and 2 000 , 00 $ and 3000,00 EUR'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end