package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(([0-9]+[\s,]*)+)(\$|EUR)`)
var str = `1000$ and 5 000 EUR and 2 000 , 00 $ and 3000,00 EUR`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}