import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|\\s)((?:[^h ]|h(?!elp))+\\/pdf\\/\\S*)(?:$|\\s)";
final String string = "Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "/dealer/us/en/pdf/simple.pdf Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "/dealer/us/en/pdf/simple.pdf Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "/dealer/us/en/pdf/simple.pdf Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "http://myhel.com/dealer/us/en/pdf/simple.pdf Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "/dealer/us/en/pdf/simple.pdf Shouldn't match: \n"
+ " /dealer/help/us/en/pdf/simple.pdf Should match: \n"
+ "/dealer/us/en/pdf/simple.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}