$re = '/(?:^|\s)((?:[^h ]|h(?!elp))+\/pdf\/\S*)(?:$|\s)/m';
$str = 'Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
http://myhel.com/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);