re = /(?:^|\s)((?:[^h ]|h(?!elp))+\/pdf\/\S*)(?:$|\s)/m
str = 'Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
http://myhel.com/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf Shouldn\'t match:
/dealer/help/us/en/pdf/simple.pdf Should match:
/dealer/us/en/pdf/simple.pdf'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end