using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/www\.google\.(?:(?:com)|(?:co\.in)).*#q=.+)";
string input = @"https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ#q=sss&safe=active
https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}