const regex = /(https?:\/\/www\.google\.(?:(?:com)|(?:co\.in)).*#q=.+)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/www\\.google\\.(?:(?:com)|(?:co\\.in)).*#q=.+)', 'gim')
const str = `https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ#q=sss&safe=active
https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}