package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?im)(https?:\/\/www\.google\.(?:(?:com)|(?:co\.in)).*#q=.+)`)
var str = `https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ#q=sss&safe=active
https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}