re = /(https?:\/\/www\.google\.(?:(?:com)|(?:co\.in)).*#q=.+)/im
str = 'https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ#q=sss&safe=active
https://www.google.co.in/?gws_rd=cr&ei=2LjgUqvJNYe6yAPZ9YHoAQ'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end