#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))"
Local $sString = "012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089" & @CRLF & _
"911" & @CRLF & _
"900" & @CRLF & _
"891" & @CRLF & _
"" & @CRLF & _
"000 010 011 987 876 765 654 543 432 321 210"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")