using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))";
string input = @"012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089
911
900
891
000 010 011 987 876 765 654 543 432 321 210";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}