use strict;
my $str = '012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089
911
900
891
000 010 011 987 876 765 654 543 432 321 210';
my $regex = qr/((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}