import Foundation
let pattern = #"((?=\b\d{3}\b)0?1?2?3?4?5?6?7?8?9?(?<=\d{3}))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
012 013 019 023 024 029 034 035 039 045 046 049 056 057 059 067 068 069 078 079 089
911
900
891
000 010 011 987 876 765 654 543 432 321 210
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)