using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?P<user>\d+)(\/group\/(?P<group>\d+))?$";
string input = @"99/group/125
99
99/group/
9group/125
99/group/125 99/group/125
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}