package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<user>\d+)(\/group\/(?P<group>\d+))?$`)
var str = `99/group/125
99
99/group/
9group/125
99/group/125 99/group/125
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}