$re = '/^(?P<user>\d+)(\/group\/(?P<group>\d+))?$/m';
$str = '99/group/125
99
99/group/
9group/125
99/group/125 99/group/125
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);