re = /^(?P<user>\d+)(\/group\/(?P<group>\d+))?$/m
str = '99/group/125
99
99/group/
9group/125
99/group/125 99/group/125
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end