// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?P<user>\d+)(\/group\/(?P<group>\d+))?$").unwrap();
let string = "99/group/125
99
99/group/
9group/125
99/group/125 99/group/125
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}