# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<!--(.*?)-->/$1/gm;t' <<< " <div class=\"col-lg-12\">
<p>The year is:</p>
<!-- <?php echo date(Y); ?> -->
</div>"