package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!--(.*?)-->`)
var str = ` <div class="col-lg-12">
<p>The year is:</p>
<!-- <?php echo date(Y); ?> -->
</div>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}