#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)<!--(.*?)-->"
Local $sString = " <div class="col-lg-12">" & @CRLF & _
" <p>The year is:</p>" & @CRLF & _
" <!-- <?php echo date(Y); ?> -->" & @CRLF & _
" </div>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)