re = /<!--(.*?)-->/m
str = ' <div class="col-lg-12">
<p>The year is:</p>
<!-- <?php echo date(Y); ?> -->
</div>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result