using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!--(.*?)-->";
string substitution = @"$1";
string input = @" <div class=""col-lg-12"">
<p>The year is:</p>
<!-- <?php echo date(Y); ?> -->
</div>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}