using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @",(?=(?:[^""]*""[^""]*"")*[^""]*$)";
string input = @"ghg,123,123,21,3,123""123,213,21,3,,213"",123213,2,31,,312,3""123213,123,,12,3"" hjgjhg , g hjgj hg ,";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}