re = /,(?=(?:[^"]*"[^"]*")*[^"]*$)/m
str = 'ghg,123,123,21,3,123"123,213,21,3,,213",123213,2,31,,312,3"123213,123,,12,3" hjgjhg , g hjgj hg ,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end