use strict;
my $str = 'ghg,123,123,21,3,123"123,213,21,3,,213",123213,2,31,,312,3"123213,123,,12,3" hjgjhg , g hjgj hg ,';
my $regex = qr/,(?=(?:[^"]*"[^"]*")*[^"]*$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}