$re = '/,(?=(?:[^"]*"[^"]*")*[^"]*$)/m';
$str = 'ghg,123,123,21,3,123"123,213,21,3,,213",123213,2,31,,312,3"123213,123,,12,3" hjgjhg , g hjgj hg ,';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);