import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=(?:[^\"]*\"[^\"]*\")*[^\"]*$)";
final String string = "ghg,123,123,21,3,123\"123,213,21,3,,213\",123213,2,31,,312,3\"123213,123,,12,3\" hjgjhg , g hjgj hg ,";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}