using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<bean:write[^\/]*\/>";
string input = @"<input name=""id"" type=""radio"" bgcolor=""<bean:write name='color'/>"" value=""<bean:write name='nameProp' property='nameVal'/>"" <logic:equal name=""checkedStatus"" value=""0"">checked</logic:equal>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}