// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<bean:write[^\/]*\/>").unwrap();
let string = "<input name=\"id\" type=\"radio\" bgcolor=\"<bean:write name='color'/>\" value=\"<bean:write name='nameProp' property='nameVal'/>\" <logic:equal name=\"checkedStatus\" value=\"0\">checked</logic:equal>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}