import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<bean:write[^\\/]*\\/>";
final String string = "<input name=\"id\" type=\"radio\" bgcolor=\"<bean:write name='color'/>\" value=\"<bean:write name='nameProp' property='nameVal'/>\" <logic:equal name=\"checkedStatus\" value=\"0\">checked</logic:equal>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}